Вопрос по информатике:
Напишите программу нахождения длин медиан m1,m2 и m3, треугольника по указанными формулами . Длина сторон a,b,c задается с клавиатуры m1=1/2*sqrt(2a^2+2b^2-c^2); m2=1/2*sqrt(2a^2+2c^2-b^2); m3=1/4*sqrt(2b^2+2c^2-a^2);.
- 04.08.2016 06:41
- Информатика
- remove_red_eye 3624
- thumb_up 15
Ответы и объяснения 2
Pascal ABC(проверьте правильность написанных вами формул...)
uses crt;
var a,b,c,m1,m2,m3 : integer;
begin
writeln('Введите длины сторон треугольника a b c');
read(a,b,c);
m1:=1/2*sqrt(2*a^2+2*b^2-c^2);
m2:=1/2*sqrt(2(a^2+2*c^2-b^2);
m3:=1/4*sqrt(2*b^2+2*c^2-a^2);
writeln('m1= ',m1,'m2= ',m2,'m3= ',m3);
end.
- 05.08.2016 12:58
- thumb_up 12
var
a, b, c: real;
function mediana(a, b, c: real): real;
begin
mediana := 1 / 2 * sqrt(2 * a * a + 2 * b * b - c * c);
end;
begin
writeln('Введите длины сторон треугольника a b c');
read(a, b, c);
writeln('m1 = ', mediana(a, b, c));
writeln('m2 = ', mediana(a, c, b));
writeln('m3 = ', mediana(b, c, a));
end.
- 06.08.2016 08:07
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.