Вопрос по информатике:
Помогите решить 2 задачи в паскале:
1)Определить равны ли все цифры заданного пятизначного числа.
2)Каждое число Фибоначчи вычисляется как f1=0, f2=1, а начиная с третьего по формуле fn=fn-1+fn-2. Составить программу, которая вычисляет n чисел Фибоначчи.
- 16.11.2015 09:58
- Информатика
- remove_red_eye 13987
- thumb_up 42
Ответы и объяснения 1
1.
Function Check(A : Longint) : Boolean;
Begin
If A>9 then Check:=((A mod 10)=(A div 10 mod 10)) and Check(A div 10) else Check:=True;
end;
Var N : Longint;
Begin
Readln(N);
Writeln(Check(N));
end.
- 17.11.2015 09:03
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.