Вопрос по информатике:
Написать программу, которая проверяет является ли введенное число двузначным или нет. Если условие выполняется, то на экран выводятся число десятков и единиц исходного числа, иначе выводится сообщение "Число двузначным не является".
- 20.03.2015 03:41
- Информатика
- remove_red_eye 16983
- thumb_up 8
Ответы и объяснения 1
//Pascal ABC.NET 3.1 сборка 1256
Var
a:integer;
s:string;
begin
readln(a);
s:=inttostr(a);
if length(s)=2 then
begin
writeln('Десятков:',s[1]);
write('Единиц:',s[2]);
end
else
writeln('Число двузначным не является');
end.
Пример ввода:
27
Пример вывода:
Десятков:2
Единиц:7
- 21.03.2015 19:58
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.