Вопрос по информатике:
Ребята!Помогите пожалуйста!Работаем в PascalABC.Нужно составить программу,которая строит изображения предмета в плоском зеркале(расстояние от предмета до зеркала вводятся с клавиатуры).Очень срочно.Заранее спасибо)
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 07.07.2015 09:44
- Информатика
- remove_red_eye 2411
- thumb_up 18
Ответы и объяснения 1
Картинка должна находиться в папке программы и иметь расширение .jpg. У меня по умолчанию название папки PABCWork.NET. И размер картинки бери не большой))
uses
graphabc;
var
a:string;
b:picture;
c:integer;
begin
writeln('Введите расстояние до зеркала');
readln(c);
writeln('Введите имя файла рисунка (.jpg): ');
readln(a);
window.Clear;
b := Picture.Create(a);
b.Load(a);
b.Draw(50, 50);
b.FlipHorizontal;
b.Draw(300+5*c,50);
end.
- 08.07.2015 15:11
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.