Вопрос по информатике:
Написать программу, вычисляющуюсуммуисреднееарифметическоепоследовательностиположительныхчисел, которыевводятсясклавиатуры.
вид экрана:
Введите числа. Для завершения последовательности нажмите ноль.
45 23 15 0
введено чисел:3
сумма чисел:83
Среднее арифметическое:27.67
- 14.01.2018 14:39
- Информатика
- remove_red_eye 7270
- thumb_up 27
Ответы и объяснения 1
В задании не сказанно что числа целые поэтому тип c: real;
Program SumAndAvg;
Uses crt;
var n:integer;
c,s,m:real;
begin
clrscr;
write('Input Numbers:');
n:=0;s:=0;
repeat
read(c);
if (c>0) then
begin
n:=n+1;
s:=s+c;
end;
until (c=0);
writeln('Numbers count =',n);
writeln('Summa =',s:2:2);
writeln('Average Value=',s/n:2:2);
readkey;
end.
- 14.01.2018 22:32
- thumb_up 4
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.