Вопрос по информатике:
Составить программу на языке Pascal для вычисления угла возвышения дальнобойного орудия по начальной скорости полета снаряда и дальности цели. Сопротивлением воздуха и высотой орудия пренебречь.
- 19.03.2018 22:40
- Информатика
- remove_red_eye 12253
- thumb_up 65
Ответы и объяснения 2
Сначала решим физическую задачу:
Дано:
v₀;
L;
Найти:
γ;
Решение:
Решим систему ур-й описывающих движение:
y(t)=v₀Δt·sinγ - ½gΔt²
x(t)=v₀Δtcosγ;
В момент времени Пусть Δt = τ x(t)=L, тогда y(t)=0 ⇒
τ= L ÷ v₀cosγ (из ур-я x(t))
из ур-я y(t)
L·g ÷ v₀²=sin2γ
γ = ½arcsin (Lg ÷ v₀²) - Это конечная формула
Ответ: γ = ½ arcsin(Lg ÷ v₀²);
Теперь код программы (PascalABC.NET):
//Если угол нужен в радианах
Program bullet_rad;
Const
g_grav = 9.8; // гравитационная постоянная g=9,8
Var
L, //Расстояние до цели
v: real; //Начальная скорость снаряда
Begin
readln (L,v); // Читаем расстояние и скорость
writeln (0.5*arcsin((L*g_grav)/sqr(v))); //Выводим ответ
End.
//Если угол нужен в градусах
Program bullet_gr;
Const
g_grav = 9.8; // гравитационная постоянная g=9,8
pi = 3.14; // постоянная п=3,14
Var
L, //Расстояние до цели
v: real; //Начальная скорость снаряда
Begin
readln (L,v); // Читаем расстояние и скорость
writeln ((90/pi)*arcsin((L*g_grav)/sqr(v))); //Выводим ответ
End.
- 21.03.2018 20:45
- thumb_up 7
Решение:
Решим систему ур-й описывающих движение:
y(t)=v₀Δt·sinγ - ½gΔt²
x(t)=v₀Δtcosγ;
В момент времени Пусть Δt = τ x(t)=L, тогда y(t)=0 ⇒
τ= L ÷ v₀cosγ (из ур-я x(t))
из ур-я y(t)
L·g ÷ v₀²=sin2γ
γ = ½arcsin (Lg ÷ v₀²) - Это конечная формула
Ответ: γ = ½ arcsin(Lg ÷ v₀²);
- 22.03.2018 17:18
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.