Вопрос по информатике:
2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).
- 04.10.2017 21:49
- Информатика
- remove_red_eye 10277
- thumb_up 85
Ответы и объяснения 2
Var max,h:integer;
begin
max:=-maxint-1;
repeat
begin
read(h);
if(h>max) then max:=h;
end;
until h >0;
writeln(max);
end.
- 05.10.2017 13:51
- thumb_up 56
using System.Collection.Generic;
List arr = new List();
int max = Convert.ToInt32(Console.ReadLine()); // максимальный порог
for(int i = 0; i < max;i++)
{
arr.Add(Convert.ToInt32(Console.ReadLine()));
}
arr.Sort();
Console.WriteLine(arr[max]);
- 06.10.2017 18:38
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.