Вопрос по информатике:
надо составить программу в паскале, в которой надо найти процент от заданного числа
- 03.05.2017 13:25
- Информатика
- remove_red_eye 4507
- thumb_up 84
Ответы и объяснения 1
Var
q: Single; // Результат. Если число будет больше, то указать Double
i: Single; // Число из которого необходимо получить результат. Если число будет больше, то указать Double
p: Single; // Процент. Если процент будет всегда целым числом, то указать Byte
begin
writeln('Введите число => ');
read(i);
writeln('Введите процент, который хотите расcчитать из введенного числа => ');
read(p);
while p < 0 do
begin
writeln('Процент не может быть меньше нуля, введите новое значение => ');
read(p);
end;
q:=(i / 100) * p;
writeln('Ваш результат из числа => ', i, ', ', p, '% = ', q);
end.
- 04.05.2017 13:31
- thumb_up 61
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.