Вопрос по информатике:
Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а)в какой день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!
- 09.06.2018 13:17
- Информатика
- remove_red_eye 8294
- thumb_up 19
Ответы и объяснения 1
а)
var
i:integer;
p:real;
begin
i:=1;
p:=10;
repeat
p:=p + p*0.1;
i:=i+1;
until p>=20;
writeln(i, ' den');
end.
б)
var
i:integer;
p,n:real;
begin
i:=1;
p:=10;
n:=p;
repeat
n:=n+n*0.1;
p:=p + n;
i:=i+1;
write(n);
writeln(' ', p);
until p>=100;
writeln(i, ' den');
end.
- 09.06.2018 16:48
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.