Вопрос по информатике:
1. Пешеход шел по пересеченной местности. Его скорость движения по равнине v1 км/ч, в гору — v2 км/ч и под гору — v3 км/ч. Время движения соответственно t1, t2 и t3 ч. Написать программу определяющую, какой путь прошел пешеход? 2. Написать программу, вычисляющую путь, пройденный лодкой, если ее скорость в стоячей воде v км/ч, скорость течения реки v1 км/ч, время движения по озеру t1 ч, а против течения реки – t2 ч.
- 20.10.2016 22:26
- Информатика
- remove_red_eye 8054
- thumb_up 93
Ответы и объяснения 1
Program Program1;
var
s,v1,v2,v3,t1,t2,t3:real;
begin
write('Введите скорость движения по равнине: ');
readln(v1);
write('Введите скорость движения в гору: ');
readln(v2);
write('Введите скорость движения под гору: ');
readln(v3);
write('Введите время движения по равнине: ');
readln(t1);
write('Введите время движения в гору: ');
readln(t2);
write('Введите время движения под гору: ');
readln(t3);
S:=t1*v1+t2*v2+t3*v3;
writeln('Путь = ',S);
end.
Program Program2;
var
s,v,v1,t1,t2:real;
begin
write('Введите скорость лодки в стоячей воде: ');
readln(v);
write('Введите скорость течения реки: ');
readln(v1);
write('Введите время движения по озеру: ');
readln(t1);
write('Введите время движения против течения реки: ');
readln(t2);
S:=t1*v+t2*(v-v1);
writeln('Путь = ',S);
end.
- 22.10.2016 00:19
- thumb_up 67
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.