Вопрос по информатике:
Составьте программу, которая формирует массив, содержащий 10 случайных целых чисел, принадлежавших промежутку [0;7], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 3,а к нечётное умножает на 4
- 03.10.2015 21:28
- Информатика
- remove_red_eye 14927
- thumb_up 31
Ответы и объяснения 1
Program Program1;
var
i:integer;
a:array [1..10] of integer;
begin
randomize;
writeln;
writeln('Массив до преобразования:');
for i:=1 to 10 do
begin
a[i]:=random(8);
write(a[i],', ');
end;
for i:=1 to 10 do
if a[i] mod 2 = 0 then
a[i]:=a[i]+3
else
a[i]:=a[i]*4;
writeln;
writeln('Массив после преобразования:');
for i:=1 to 10 do
write(a[i],', ');
end.
- 05.10.2015 17:11
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.