Вопрос по информатике:
Написать программу. Программа должна осуществлять ввод и печать исходного одномерного массива; выполнять в соответствии с условиями действия и печатать результаты. Вычислить сумму ненулевых чисел, стоящих на четных местах, и подсчитать количество чисел, принадлежащих промежутку [M, K].
- 09.05.2015 07:33
- Информатика
- remove_red_eye 6571
- thumb_up 6
Ответы и объяснения 1
var a:array[1..10,1..10]of integer;
i,j,m,k,s:integer;
begin
for i:=1 to 10 do for j:=1 to 10 do readln(a[i,j]);
for i:=1 to 10 do begin for j:=1 to 10 do write(a[i,j],' '); if j=10 then writeln; end;
for i:=1 to 10 do
for j:=1 to 10 do
if (a[i,j]0) and (i mod 2=0) then s:=s+a[i,j];
writeln(s);
readln(m,k);
s:=0;
for i:=1 to 10 do
for j:=1 to 10 do
if (a[i,j]>=m) and (a[i,j]<=k) then s:=s+1;
writeln(s);
end.
- 09.05.2015 10:44
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.