Вопрос по информатике:
Составьте программу ,определяющую максимальный элемент и его индексы матрицы А размером M x N
- 05.01.2018 21:15
- Информатика
- remove_red_eye 7150
- thumb_up 78
Ответы и объяснения 1
Var a:array[1..10,1..10]of integer; неудобно var a:array[1..10,1..10]of integer;
max,i1,j1,i,j,k,m,n:integer;
begin
readln(m,n);
for i:=1 to m do
for j:=1 to n do
readln(a[i,j]);
max:=a[1,1];
i1:=1;
j1:=1;
for i:=1 to m do begin
for j:=1 to n do begin
if a[i,j]>max then begin max:=a[i,j]; i1:=i; j1:=j; end;
end;
end;
writeln(max,' ',i1,' ',j1);
end.
- 06.01.2018 10:28
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.