Вопрос по информатике:
составить программу, которая формирует массив, содержащий 15 случайных целых чисел, принадлежащий промежутку [0; 8], и преобразует элементы массива по следующему правилу: к чётному числу прибавляет 1, а нечётное умножает на 2.
- 03.02.2018 10:46
- Информатика
- remove_red_eye 5374
- thumb_up 79
Ответы и объяснения 1
var
i: integer;
a: array [1..15] of integer;
begin
write('Исходный массив: ');
for i:= 1 to 15 do //Формируем и распечатываем массив
begin
a[i]:= random(8);
write(a[i],' ');
end;
writeln; //Перевод на новую строку
write('Преобразованный массив: ');
for i:= 1 to 15 do
begin
if a[i] mod 2 = 0 then a[i]:= a[i] + 1 {Если элемент массива с индексом i четный, то прибавляем к нему 1, иначе умножаем на 2}
else a[i]:= a[i] * 2;
write(a[i], ' ');
end;
writeln; {Перевод на новую строку, чтобы при повторном запуске программы сформированный массив печатался на новой строке}
end.
Отметь решение, как лучшее плиз)
- 04.02.2018 06:38
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.