Вопрос по информатике:
Составьте программу нахождения наибольшего общего делителя трех чисел,используя следующую формулу: НОД(А,В,С)=НОД(НОД(А,В),С).
- 18.09.2017 16:11
- Информатика
- remove_red_eye 2111
- thumb_up 94
Ответы и объяснения 1
#include
#include
using namespace std;
int NOD( int a, int b)
{
int c=1;
int d;
if(a>b)
d=b;
else
d=a;
for(int j=1;j<=d;j++)
{
if(a%j==0 && b%j==0)
c=j;
}
return c;
}
int main()
{
int A,B,C;
cout<<"Введите А"< cin>>
- 19.09.2017 21:58
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.