Вопрос по информатике:
Написать программу в паскале.
Дано натуральное число Х.Найти сумму квадратов чётных цифр в числе.
- 22.05.2015 00:40
- Информатика
- remove_red_eye 16444
- thumb_up 7
Ответы и объяснения 1
Var
x,d,s:longint;
begin
Writeln('Введите натуральное число: '); Read(x);
s:=0;
while x>0 do begin
d:=x mod 10;
if d mod 2=0 then s:=s+d*d;
x:=x div 10
end;
Writeln('Сумма квадратов четных цифр равна ',s)
end.
Пример
Введите натуральное число:
14702
Сумма квадратов четных цифр равна 20
- 23.05.2015 16:21
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.