Вопрос по информатике:
№1
Даны два действительных числа, не равные друг другу. Меньшее из этих двух чисел заменить половинной их суммы, а большее-их удвоенным произведением.
№2
Определить корректность введенной даты(число-от 1 до 31, месяц-от 1 до 12). Если введены неверные данные, то сообщить об этом.
№3
Написать программу, которая находит наибольшее из трех введенных чисел и выводит его на экран.
- 10.10.2015 09:22
- Информатика
- remove_red_eye 15198
- thumb_up 33
Ответы и объяснения 2
1)
var
a,b,x,y:real;
begin
readln(a,b);
x:=(a+b)/2;
y:=2*a*b;
if a>b then
begin
a:=y;
b:=x;
end
else
begin
a:=x;
b:=y;
end;
writeln('a=',a:8:3);
writeln('b=',b:8:3);
end.
2)
var
d,m:integer;
begin
readln(d,m);
if (d31) then writeln ('день введен неверно');
if (m12) then writeln ('месяц введен неверно');
end.
3)
var
a,b,c:integer;
begin
readln(a,b,c);
if (a>b) and (a>c) then writeln(a);
if (b>a) and (b>c) then writeln(b);
if (c>a) and (c>b) then writeln(c);
end.
- 11.10.2015 02:32
- thumb_up 48
1)
var a,b,c,d:real;
begin
read(a,b);
c:=(a+b)/2;
d:=2*a*b;
if a>b then begin
a:=d;
b:=c;
end;
if a
a:=c;
b:=d;
end;
writeln(a,' ',b);
end.
2)
var a,b:integer;
begin
read(a,b);
if (a31) then writeln(' день введен неправильно');
if (b12) then writeln(' месяц введен неправильно');
end.
3)
var a,b,c:real;
begin
read(a,b,c);
if (a>b)and(a>c)then writeln(a);
if (b>a)and(b>c)then writeln(b);
if (c>b)and(c>a)then writeln(c);
end.
- 12.10.2015 04:48
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.