Вопрос по информатике:
Составьте программу, которая формирует массив из шестнадцати целых чисел от -20 до 20 и находит в этом массиве индексы элементов, значения которых кратным трём.
- 24.05.2018 20:31
- Информатика
- remove_red_eye 6520
- thumb_up 93
Ответы и объяснения 2
Как-то так...
Program g;
Var
A, B : Integer;
N : Integer;
S : Integer;
z:array[0..16] of integer;
i : Integer;
v:integer;
Begin
A:=(-20);
B:=20 ;
N:=16 ;
For i := 1 To N Do
Begin
S := Trunc(Random(B-A)+A);
WriteLn (i:2,'-е случайное число:',S:4);
End;
begin
writeln('Индексы элементов кратных 3:');
for v:=0 to 16 do begin
z[v]:=random(40)-20;
if z[v] mod 3 = 0 then write(v, ' ')
end;
end;
End.
- 25.05.2018 06:35
- thumb_up 18
var
i:integer;
a:array[1..16]of integer;
begin
for i:=1 to 16 do
begin
a[i]:=random(40)-20;
if a[i] mod 3=0 then write(i,' ');
end;
writeln;
end.
- 26.05.2018 18:57
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.