Вопрос по информатике:
Составить программу, в которой осуществляется ввод трёх целых чисел с клавиатуры и вывод на экран монитора значения их суммы.
- 06.07.2017 02:18
- Информатика
- remove_red_eye 8066
- thumb_up 59
Ответы и объяснения 1
Ну вот так это будет выглядеть с ветвлением и возможностью повторять вычисления без повторного запуска программы.
var a,b,c,d,z:integer;
begin
writeln('Введите 1 число');
read(a);
writeln('Введите 2 число');
read (b);
writeln('Введите 3 число');
read (c);
d:=a+b+c;
writeln('Сумма чисел ',a,'+',b,'+',c,'=',d);
writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет');
read (z);
while (z = 1) do
begin
writeln('Введите 1 число');
read(a);
writeln('Введите 2 число');
read (b);
writeln('Введите 3 число');
read (c);
d:=a+b+c;
writeln('Сумма чисел ',a,'+',b,'+',c,'=',d);
writeln ('Хотите ли вы решить еще один пример? 1-ДА, 0-Нет');
read (z);
end;
end.
- 07.07.2017 05:33
- thumb_up 54
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.