Вопрос по информатике:
Укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 2, а потом 9.
var x, a,b: integer;
begin
readln(x);
a:=0; b:=0;
while x>0 do
begin
a:=a+1;
b:= b+(x mod 10);
x:=x div 10;
end;
writeln(a); write(b) ;
end.
- 12.01.2017 13:56
- Информатика
- remove_red_eye 15316
- thumb_up 39
Ответы и объяснения 1
Переменная "b" должна вывести 9. В программе берется остаток числа от деления на 10 и прибавляется переменная "b". Сумму "9" можно представить, как 9+0, 8+1, 7+2, 6+3, 5+4. Наибольшее число, которое можно составить из предложенных сумм - 90.
Ответ: 90.
- 13.01.2017 15:12
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.