Вопрос по информатике:
помогите плиз составить задачу )))в массиве хранится информация о среднедневной температуре декабря. составьте программу, которая подсчитает, сколько в декабре было дней с нулевой, отрицательной и положительной температурой
- 10.05.2018 07:00
- Информатика
- remove_red_eye 8893
- thumb_up 77
Ответы и объяснения 1
program xxx;
var i, m, p, n : integer;
t : array[1..31] of real;
begin
writeln('введите температуру ')
for i:=1 to 31 do
readln(t[i]);
m:=0; p:=0; n:=0;
for i:=1 to 31 do
begin
if t[i]<0 then m:=m+1;
if t[i]>0 then p:=p+1;
if t[i]=0 then n:=n+1
end;
writeln('Дней с отрицательной температурой было - ', m);
writeln('Дней с положительной температурой было - ', р);
writeln('Дней с нулевой температурой было - ', n);
readln
end.
- 11.05.2018 03:10
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.