Вопрос по информатике:
Написать программу на Языке программирования Паскаль для вывода массива где каждое последующее число будет прибавляется к заднему, то есть к примеру 9 7 9+7=16 значит у нас будет такой массив 9 7 16 и т.д.
- 20.08.2018 14:15
- Информатика
- remove_red_eye 8712
- thumb_up 46
Ответы и объяснения 2
const MAX = 250;var
a: array [1..MAX] of integer;
i, n: integer;
begin
randomize;
write('Размер массива: ');
readln(n);
a[1] := random(31) - 15;
a[2] := random(31) - 15;
write(a[1]:4, a[2]:4);
for i := 3 to n do
begin
a[i] := a[i - 2] + a[i - 1];
write(a[i]:5);
end;
writeln;
end.
- 21.08.2018 20:23
- thumb_up 2
// без массива
begin var (a, b) := ReadInteger2('Задай два первых числа ');
var n := ReadInteger('Сколько всего чисел надо?');
Print(a, b);
for var i := 3 to n do
begin
(a, b) := (b, a + b);
Print(b)
end
end.
// с массивом
begin
var n := ReadInteger('Сколько всего чисел надо?');
var a := new integer[n];
(a[0], a[1]) := ReadInteger2('Задай два первых числа ');
for var i := 2 to n - 1 do
a[i] := a[i - 1] + a[i - 2];
a.Println
end.
- 22.08.2018 23:02
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.