Вопрос по информатике:
Напишите программу, при помощи которой можно подсчитать расходы на доставку мебели. Исходные данные для расчета – номер этажа и информация о наличии и типе лифта (грузовой или обычный). C++
- 20.01.2018 17:34
- Информатика
- remove_red_eye 4759
- thumb_up 34
Ответы и объяснения 1
#include stdlib.h
#include
using namespace std;
int main() {
setlocale(LC_ALL, "Russian");
int floor;
char lift, type0;
double price_floor;
double price_elevator;
double price_type;
double total_price;
bool elevator;
cout << "Введите номер этажа: ";
cin >> floor;
if (floor == 1 || floor <= 3) price_floor=1;
if (floor 3) price_floor=2;
if (floor 6) price_floor=3;
else if price_floor=4;
cout << "Имеется ли в вашем помещении лифт? "; //Ответ + или -
cin >> lift;
switch (lift) {
case '+':
price_elevator=1;
elevator=true;
break;
case '-':
price_elevator=2;
break;
}
if (elevator) {
cout << "Грузоподъемный? ";
cin >> type0;
switch (type0) {
case '+':
price_type=1
break;
case '-':
price_type=2;
break;
}
}
else if cout <<"\n";
cout <<"\n";
total_price=price_elevator + price_floor + price_type;
cout << "Конечная цена: " << total_price <
return 0;
}
- 21.01.2018 13:21
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.