Вопрос по информатике:
Составить программу, печатающую значение true, если указанное высказывание является истинным, и false в противном случае: сумма цифр данного трехзначного числа N является четным числом.
Код для C#
- 23.06.2018 00:14
- Информатика
- remove_red_eye 9138
- thumb_up 37
Ответы и объяснения 1
using System;
namespace App
{
class MainClass
{
public static void Main(string[] args)
{
Console.Write("Введите число N: ");
int number;
while(!int.TryParse(Console.ReadLine(),out number))
{
Console.Write("Ошибка, введите корректное число: ");
}
if(number >= 100 && number <= 999)
{
int sum = 0;
while(number != 0)
{
sum += number % 10;
number /= 10;
}
Console.WriteLine(sum % 2 == 0);
}
else
{
Console.WriteLine("Данное число не трехзначное");
}
}
}
}
- 23.06.2018 10:27
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.