Вопрос по информатике:
Нужно сделать задачу в CodeBlocks, на языке C (не C++)
Сама задача:
"Написать программу, которая проверяет, является ли год високосным.
Ниже приведен рекомендуемый вид экрана во время
работы программы. Данные, введенные пользователем, выделены
полужирным шрифтом.
Введите год, например 2000, и нажмите
-> 2001
2000 год - не високосный"
Желательно объяснение еще функций, переменных и т.д
- 05.09.2017 05:48
- Информатика
- remove_red_eye 2910
- thumb_up 36
Ответы и объяснения 1
#include
main() {
int y; // Переменная, в которой будет хранится год
scanf("%d",&y); // Вводим год
if (y%4 != 0) printf("Обычный"); // Проверяемый на високосный ли год
else
if (y%100 == 0 && y%400 != 0) printf("Обычный"); // Проверяем год на исключения
else printf("Високосный");
printf("\n");
}
- 06.09.2017 20:00
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.