Вопрос по информатике:
Написать программу, которая подсчитывает количество положительных и отрицательных элементов файла целых чисел des.dat. Pascal ABC
- 20.09.2017 12:37
- Информатика
- remove_red_eye 18786
- thumb_up 48
Ответы и объяснения 1
f:file of integer;
i,n,kp,ko:integer;
begin
{ создать файл }
randomize;
assign(f,'des.dat');
rewrite(f);
for i:=1 to 20 do
begin
n:=random(101)-50;
Write(n,' ');
Write(f,n)
end;
close(f);
Writeln;
{ работа с файлом }
ko:=0;
kp:=0;
reset(f);
while not eof(f) do
begin
Read(f,n);
if n>0 then Inc(kp)
else if n<0 then Inc(ko)
end;
close(f);
Writeln('Положительных ',kp,', отрицательных ',ko)
end.
- 21.09.2017 19:59
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.