Вопрос по информатике:
Написать программу, которая пользуясь двумя указателями на массивы целых чисел, копирует один массив в другой так, чтобы во втором массиве элементы находились в обратном порядке.
на С
- 21.12.2017 09:56
- Информатика
- remove_red_eye 14584
- thumb_up 31
Ответы и объяснения 1
#include
#include
void print_array(int* numbers,int count)// Функция для вывода элементов массива
{
for(int i = 0;i { printf("%d ",numbers[i]); } printf("\n"); } void rechange(int *first_array,int *second_array,int count)// Функция для перезаписи одного массива в другой. //Элементы первого массива запишутся во второй в обратном порядке. { int x = count - 1; for(int i = 0;i { second_array[x--] = first_array[i]; } } int main(int argc, char** argv) { const int ARRAY_ELEMENTS_COUNT = 15; int *first_array = (int*)malloc(sizeof(first_array) * ARRAY_ELEMENTS_COUNT); // Выделить память для первого массива int *second_array = (int*)malloc(sizeof(second_array) * ARRAY_ELEMENTS_COUNT); //Выделить память для второго массива for(int i = 0;i { first_array[i] = std::rand() % 100 + 1; second_array[i] = std::rand() % 100 + 1; } print_array(first_array,ARRAY_ELEMENTS_COUNT); // Выводим первый массив print_array(second_array,ARRAY_ELEMENTS_COUNT); // Выводим второй массив rechange(first_array,second_array,ARRAY_ELEMENTS_COUNT); print_array(second_array,ARRAY_ELEMENTS_COUNT); // Выводим второй массив //в который записаны элементы первого массива в обратном порядке free(first_array); // Очищаем память free(second_array); // Очищаем память return 0; }
- 22.12.2017 13:14
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.