Вопрос по информатике:
Написать программу, которая проверяет является ли строка, введенная с клавиатуры палиндромом (пробелы игнорировать). Pascal ABC
- 16.05.2018 00:07
- Информатика
- remove_red_eye 6555
- thumb_up 41
Ответы и объяснения 1
s:string;
i,n:byte;
p:boolean;
begin
Write('Введите строку: ');
Readln(s);
n:=Length(s);
for i:=n downto 1 do
if s[i]=' ' then Delete(s,i,1);
n:=Length(s);
p:=true;
for i:=1 to n div 2 do
if s[i]s[n-i+1] then
begin
p:=false;
break
end;
if p then Writeln('Палиндром')
else Writeln('Не палиндром')
end.
- 17.05.2018 12:22
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.