Вопрос по информатике:
Написать программу, которая запрашивает слово и проверяет, является ли это слово палиндромом. Pascal ABC
- 05.11.2015 12:50
- Информатика
- remove_red_eye 13385
- thumb_up 5
Ответы и объяснения 2
s:string;
i,n:byte;
p:boolean;
begin
Write('Введите слово: ');
Readln(s);
n:=Length(s);
p:=true;
for i:=1 to n div 2 do
if s[i]s[n-i+1] then
begin
p:=false;
break
end;
if p then Writeln('Палиндром')
else Writeln('Не палиндром')
end.
- 06.11.2015 01:40
- thumb_up 32
var
s: string;
function Invert(s: string): string;
var
i: integer;
t: string;
begin
t := '';
for i := 1 to length(s) do
t := s[i] + t;
Invert := t;
end;
begin
Write('Введите слово: ');
Readln(s);
s := Trim(s);
s := Uppercase(s);
if Invert(s) = s then
Writeln('Палиндром')
else
Writeln('Не палиндром');
end.
- 07.11.2015 06:32
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.