Вопрос по информатике:
Составить программу, которая будет считывать введённое четырехзначное число. Каждую цифру этого числа необходимо вывести в новой строке
- 20.03.2018 16:38
- Информатика
- remove_red_eye 13645
- thumb_up 21
Ответы и объяснения 2
begin
var num: integer;
while true do
begin
num := ReadlnInteger('введите 4-х значное число, num =');
if (num > 999) and (num <= 9999)
then break;
end;
var str := num.ToString;
foreach var x in str do
Println(x)
end.
- 21.03.2018 04:48
- thumb_up 8
begin
write('Введите четырехзначное число: ');
readln(a);
f:=a div 1000;
writeln(f);
a:=a-1000*f;
f:=a div 100;
writeln(f);
a:=a-100*f;
f:=a div 10;
writeln(f);
a:=a-10*f;
writeln(a);
end.
- 22.03.2018 08:06
- thumb_up 35
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.