Вопрос по информатике:
Кондуктор автобуса каждое утро получает билеты, для того чтобы раздать их своим пассажирам. В начале рабочего дня он запоминает номер первого билета, а в конце – последнего. Определите, сколько счастливых билетов получили пассажиры данного автобуса.
PLEASE
- 09.08.2018 17:21
- Информатика
- remove_red_eye 7001
- thumb_up 35
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
function IsHappy(n:integer):boolean;
begin
var L:=new List;
while n>0 do begin
L.Add(n mod 10);
n:=n div 10
end;
n:=L.Count;
n:=n div 2 + n mod 2;
Result:=L[:n].Sum=L[n:].sum
end;
begin
var (a,b):=ReadInteger2('Введите номера первого и последнего билета:');
Writeln('Счастливых билетов - ',Range(a,b).Where(t->IsHappy(t)).Count)
end.
- 01.01.1970 00:00
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.