Вопрос по информатике:
Нужно написать программу на с++, которая будет решать введенные в нее производные, например 2x^5 = 10x^4, cosx = - sinx, вычислять ответ производной не нужно.
- 15.07.2016 00:26
- Информатика
- remove_red_eye 9669
- thumb_up 41
Ответы и объяснения 1
#include
#include
#include
#include
int main()
{
std::vector
std::make_pair("2x^5", "10x^4"),
std::make_pair("cosx", "-sinx")
};
std::string user_fx;
std::cin >> user_fx;
for (const auto& i : deriv_sheet )
if (i.first.compare(user_fx) == 0)
std::cout << i.second;
}
- 16.07.2016 03:29
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.