Вопрос по информатике:
Составить программу для задачи: Ввести трехзначное число, и вывести через запятую его отдельные цифры.Pascal
- 12.09.2017 13:11
- Информатика
- remove_red_eye 12246
- thumb_up 40
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
1. Самое простое "арифметическое" решение
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
Writeln(n div 100,',',(n div 10) mod 10,',',n mod 10)
end.
Пример
n= 318
3,1,8
2. "Арифметическое" решение с циклом, цифры в обратном порядке
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
while n>10 do begin
Write(n mod 10,',');
n:=n div 10
end;
Writeln(n mod 10)
end.
Пример
n= 318
8,1,3
3. "Арифметическое" решение с массивом
begin
var n:=Abs(ReadInteger('n=')); // защита от отрицательных чисел
var a:array[1..3] of integer;
var i:=3;
while n>0 do begin
a[i]:=n mod 10;
i-=1;
n:=n div 10
end;
Writeln(a[1],',',a[2],',',a[3])
end.
Пример
n= 318
3,1,8
4. Решение с символьной строкой
begin
Abs(ReadInteger('n=')).ToString.ToCharArray.Println(',')
end.
Пример
n= 318
3,1,8
- 13.09.2017 14:09
- thumb_up 3
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.