Вопрос по информатике:
Напишите программу на С# или на алгоритмическом языке, которая бы определяла, является данное число N(≤ 10000) степенью числа 5. В качестве ответа требуется либо написать соответствующую степень пятёрки, либо сообщение «No».
Помогите ПОЖАЛУЙСТА (нужно срочно).
- 25.07.2018 05:37
- Информатика
- remove_red_eye 19769
- thumb_up 37
Ответы и объяснения 1
namespace ConsoleApp1
{
class Program
{
static void Main(string[] args)
{
double a = Convert.ToDouble(Console.ReadLine());
double c = Math.Log(a, 5);
if (c == Math.Truncate(c) )
{
Console.WriteLine(c);
}
else
{
Console.WriteLine("NO");
}
Console.ReadKey();
}
}
}
- 26.07.2018 16:25
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.