- 26.04.2018 02:51
- Информатика
- remove_red_eye 11386
- thumb_up 10
Ответы и объяснения 1
78₁₀>48₁₀
Номер 2.
0 - нет остатка, 1 - есть остаток
824:2=412 (0)
412:2=206 (0)
206:2=103 (0)
103:2=51 (1)
51:2=25 (1)
25:2= 12 (1)
12:2=6 (0)
6:2=3 (0)
3:2= 1 (1)
Запишем это число снизу вверх и добавим в начале 1
1100111000₂ нужно перевести обратно
1*2³+1*2⁴+1*2⁵+1*2⁸+1*2⁹=8+16+32+256+512=824₁₀
Номер 3.
10110010₂ и 110000₂ переведем в 10-ую систему счисления
запишу кратко
2¹+2⁴+2⁵+2⁷=2+16+32+128=178₁₀
А число 110000 мы уже переводили в первом номере - 48
Выполним условия
1.Сложим 178 и 48=226
2.Вычтем 48 от 178=130
3.Умножим 178 на 48=8544
Номер 4.
Тут видимо нужно написать программу. Напишу ее на PascalABC
program chetnie_shisla;
var a,b,s:integer;
k:byte;
Begin
k:=0; s:=0;
writeln ('введите первое число'); read(a);
writeln ('введите второе число'); read(b);
s:=a+b;
if s mod 2=0 then k:=k+1;
writeln(s);
Номер 5.
program chisla;var a:integer;Begina:=6;while a<=38 do begin a:=a+4; write(' ',a); end;end.Номер 6.
program leto;
var c:integer;
writeln ('введите число от 6 до 8'); read(c);
if c=6 then writeln ('Июнь');
if c=7 then writeln ('Июль');
if c=8 then writeln ('Август');
end.
Номер 7.
Щас подумаю, в комменты напишу :)
- 28.04.2018 00:57
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.