Вопрос по информатике:
Написать программу на Pascal.
Ввести 10 случайных чисел и посчитать количество чётных и нечётных .
- 16.03.2017 01:58
- Информатика
- remove_red_eye 19105
- thumb_up 38
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println;
var k:=a.Where(t->t.IsOdd).Count;
Writeln('Четных чисел ',k,', нечетных ',10-k)
end.
Пример
-45 -50 -29 12 35 -50 -33 -16 50 -24
Четных чисел 4, нечетных 6
- 17.03.2017 21:29
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.