Вопрос по информатике:
Составить программу которая определяет наличие одинаковых цифр в произвольном 3-значном числе
- 11.09.2017 14:35
- Информатика
- remove_red_eye 6988
- thumb_up 39
Ответы и объяснения 2
Внимание! Если программа не работает, обновите версию!
begin
var n:=Abs(ReadInteger('Введите целое трехзначное число'));
if n.Between(100,999) then
if n.ToString.Select(c->c).Distinct.Count<3 then
Writeln('Есть одинаковые цифры')
else Writeln('Нет одинаковых цифр')
else Writeln('Число должно быть трехзначным')
end.
- 12.09.2017 06:44
- thumb_up 3
begin
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1=a2)or(a1=a3)or(a2=a3)
then writeln('Одинаковые цифры есть')
else writeln('Одинаковых цифр нет');
end.
Пример:
121
Одинаковые цифры есть
- 13.09.2017 02:46
- thumb_up 39
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.