Вопрос по информатике:
Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, кратное 5 и оканчивающееся на 0. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 5 и оканчивающееся на 0. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — максимальное число, кратное 5 и оканчивающееся на 0.
- 10.09.2018 01:32
- Информатика
- remove_red_eye 7736
- thumb_up 47
Ответы и объяснения 1
n, a, i, max: longint;
begin
readln(n);
max := -30001;
for i := 1 to n do begin
read(a);
if (a > max) and (a mod 10 = 0) then
max := a;
end;
writeln(max);
end.
- 11.09.2018 19:03
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.