Вопрос по информатике:
Ввести двузначное целое число х<15. Написать программу перевода его в восьмеричную систему счисления.(Паскаль)
- 05.12.2017 02:51
- Информатика
- remove_red_eye 10594
- thumb_up 19
Ответы и объяснения 2
s:string;
begin
write('Введите число в 10 СС: ');
readln(n);
s:='';
while n>0 do
begin
s:=zs[n mod 8+1]+s; //берем остаток от деления на 8 и эту цифру пишем в начало строки
n:=n div 8 //сокращаем число
end;
write('Число в 8 СС: ',s);
readln
end.
- 06.12.2017 01:30
- thumb_up 48
Если число целое и двухзначное меньше 15, то это числа 10, 11, 12, 13 и 14. В восьмеричном представлении они больше десятичного значения на 2, т.е. 10₁₀ = 12₈, 11₁₀ = 13₈, ... 14₁₀ = 16₈
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var n:=ReadInteger('Введите число от 10 до 14:');
Writeln('В восьмеричной системе оно записывается как ',n+2)
end.
Пример
Введите число от 10 до 14: 13
В восьмеричной системе оно записывается как 15
- 07.12.2017 19:06
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.