Вопрос по информатике:
Задание для паскаля
Є цілочисельний масив n*m елементів. Знайти номер рядка з мінімальною сумою модулів елементів.
(Есть целочисленный массив n * m элементов. Найти номер строки с минимальной суммой модулей элементов.)
написать программу и объяснить что к чему
- 15.02.2016 14:09
- Информатика
- remove_red_eye 6291
- thumb_up 37
Ответы и объяснения 2
Внимание! Если программа не работает, обновите версию!
begin
var (n,m):=ReadInteger2('Количество строк и столбцов в массиве:');
Writeln('*** Исходный массив ***');
var a:=MatrRandom(n,m,-99,99);
a.Println(4); Writeln(4*a.ColCount*'-');
Writeln(a.Rows.Select(r->r.Select(t->Abs(t)).Sum).ToArray.IndexMin+1)
end.
- 16.02.2016 05:14
- thumb_up 39
const
maxn = 100;
type
myarr = array [1..maxn, 1..maxn] of longint;
var
a: myarr;
n, m, i, j, sum, ini, max: longint;
begin
readln(n, m);
max := 0;
for i := 1 to n do begin
sum := 0;
for j := 1 to m do begin
read(a[i, j]);
sum := sum + abs(a[i, j]);
end;
if (sum > max) then begin
ini := i;
max := sum;
end;
end;
writeln(ini);
end.
- 17.02.2016 03:50
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
