Вопрос по информатике:
ПОМОГИТЕ С ИНФОРМАТИКОЙ!!!!
Написать программу в Паскале
1. Заданы стороны треугольника. Проверить является ли он прямоугольным
- 26.08.2017 20:13
- Информатика
- remove_red_eye 14784
- thumb_up 26
Ответы и объяснения 1
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!
begin
var (a,b,c):=ReadReal3('Введите через пробел или Enter стороны:');
if a>c then Swap(a,c);
if b>c then Swap(b,c);
if c*c=a*a+b*b then Writeln('Треугольник прямоугольный')
else Writeln('Треугольник не прямоугольный')
end.
Пример
Введите через пробел или Enter стороны: 6 8 10
Треугольник прямоугольный
- 27.08.2017 09:13
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.