Вопрос по информатике:
Помогите составить программу в паскале.Расчет значения функции
x-2/sqrt(x*x-2*x) при х из отрезка (-10;10) изменяющимся с шагом 1.Должен быть цикл for.Заранее спасибо
- 06.09.2017 00:27
- Информатика
- remove_red_eye 16689
- thumb_up 14
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
for var x:=-10 to 10 do
Writeln(x:3,x-2/Sqrt(x*x-2*x):15:10)
end.
Как видно из представленных во вложении результатов, современный Паскаль легко справляется и с отрицательным значением подкоренного выражения (NaN - Not a Number - не число) и с делением на ноль (-infinity - минус бесконечность).
- 07.09.2017 12:42
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.