Вопрос по информатике:
Напишите программу,в которой осуществляется ввод целых чисел (ввод осуществляется до тех пор,пока не будет введён ноль) подсчет суммы и среднего арифметического введённых положительных чисел и определение максимального (наибольшего) из введённых чисел.Используйте оператор repeat.
- 07.02.2017 19:02
- Информатика
- remove_red_eye 7054
- thumb_up 36
Ответы и объяснения 1
a, i, max: integer;
sum: real;
begin
max := 0;
sum := 0;
i := 0;
repeat
write('Введите число: ');
readln(a);
if a > 0
then begin
sum := sum + a;
i := i + 1;
end;
if max < a
then max := a;
until a = 0;
writeln(#10,'Сумма = ', sum, #10, 'Среднее арифметическое = ', sum / i, #10, 'Наибольшее число - ', max);
end.
- 08.02.2017 23:54
- thumb_up 8
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.