Вопрос по информатике:
Написать программу сортировки массива по возрастанию из 10 случайных элементов.паскаль
- 04.08.2018 11:06
- Информатика
- remove_red_eye 7461
- thumb_up 15
Ответы и объяснения 2
var
a:array[1..10] of integer;
i,j,x:integer;
begin
randomize;
for i:=1 to 10 do
a[i]:=random(10000)-5000;
for i:=1 to 10 do
write(a[i],' ');
writeln;
for i:=2 to 10 do
for j:=10 downto i do
if(a[j-1]>a[j]) then begin
x:=a[j-1];
a[j-1]:=a[j];
a[j]:=x;
end;
for i:=1 to 10 do
write(a[i],' ');
end.
- 05.08.2018 16:15
- thumb_up 21
Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(10,-50,50); a.Println; a.Sorted.Println
end.
Пример
32 23 -44 -39 40 23 -27 13 -36 -41
-44 -41 -39 -36 -27 13 23 23 32 40
- 06.08.2018 15:42
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.