Вопрос по информатике:
Составьте программу заполнения массива из 100 чисел случайными значениями из диапазона от -20 до 20. Подсчитайте в этом массиве количество положительных и количество отрицательных значений.
- 16.05.2018 20:10
- Информатика
- remove_red_eye 16125
- thumb_up 22
Ответы и объяснения 1
i,pol,otr: Integer;
begin
for i:=0 to 99 do
begin
a[i]:=random(41)-20;
end;
for i:=0 to 99 do
begin
if a[i]>0 then Inc(pol);
if a[i]<0 then Inc(otr);
end;
writeln('Положительных: ',pol);
writeln('Отрицательных: ',otr);
end.
- 17.05.2018 21:34
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.