Вопрос по информатике:
Напишите программу с помощью Паскаля.
Сформировать массив случайным образом(длина массива 20).Найти в нем среднее арифметическое.Сформировать новый массив из элементов первого больших среднего арифметического.
- 22.10.2017 19:36
- Информатика
- remove_red_eye 2358
- thumb_up 14
Ответы и объяснения 2
var i, j: integer;
var s: real;
var m: array[1..20] of integer;
var n: array[1..20] of integer;
{ формируем массив и заодно вычисляем сумму элементов }
for i := 1 to 20 do begin
m[i] := random(1000);
s := s + m[i];
end;
{ печать массива }
for i := 1 to 20 do begin
writeln(m[i]);
end;
writeln('');
{ среднее арифметическое }
s := s / 20;
writeln(s);
j := 0;
for i := 1 to 20 do begin
if m[i] > s then begin
j := j + 1;
n[j] := m[i];
end;
end;
writeln('');
for i := 1 to j do begin
writeln(n[i]);
end;
end.
- 23.10.2017 02:39
- thumb_up 15
Программа формирует новый массив со смещением в лево
Program sector;
const
n=10;
var
a,b:array [1..n,1..n] of integer;
z:real;
i,j,k: byte;
begin
randomize;
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=random (40);
a[i,j]:=a[i,j]-20;
write(a[i,j]:4);
end;
writeln;
end;
z:=0;
for i:=1 to n do
for j:=1 to i do
z:=z+a[i,j];
z:=z/(n*n);
writeln('srednee = ',z);
for i:=1 to n do begin
k:=1;
for j:=1 to n do
if a[i,j] > z then begin
b[i,k]:=a[i,j];
write(b[i,k]:4);
k:=k+1;
end;
writeln;
end;
readln;
end.
- 24.10.2017 18:08
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.