Вопрос по информатике:
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок.
Написать программу в Pascal
- 08.11.2015 17:24
- Информатика
- remove_red_eye 1428
- thumb_up 32
Ответы и объяснения 1
var
all,last,seven: real;
ii,day: integer;
begin
last := 10;
all := 10;
day := 0;
for ii := 1 to 10 do
begin
last := last+(last*0.1);
all := all+last;
if ii=7 then
seven := all;
writeln('day ',ii,': ',round(last));
if day = 0 then
if all > 100 then
day := ii;
end;
writeln('Overall distance of 7 days: ',seven);
writeln('Distance 100km is reached at ',day,' day');
end.
- 09.11.2015 14:09
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.