Вопрос по информатике:
Написать программу,находящую скорость или время или пройденное расстояние в зависимости от запроса пользователя.(авс паскаль)
- 10.07.2018 06:01
- Информатика
- remove_red_eye 8585
- thumb_up 51
Ответы и объяснения 1
var
x: String[10];
t, v, s: Real;
begin
Write('Что будем искать?: ');
ReadLn(x);
if x = 'скорость' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите время: ');
ReadLn(t);
WriteLn('Скорость=', s / t);
end
else if x = 'время' then
begin
Write('Введите расстояние: ');
ReadLn(s);
Write('Введите скорость: ');
ReadLn(v);
WriteLn('Время=', s / v);
end
else if x = 'расстояние' then
begin
Write('Введите скорость: ');
ReadLn(v);
Write('Введите время: ');
ReadLn(t);
WriteLn('Расстояние=', v * t);
end
else
WriteLn('Неверно указано, что будем искать.');
end.
- 11.07.2018 18:37
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.