Вопрос по информатике:
100 баллов! Составьте программу на языке паскаль: Вычислите длину(l) отрезка АВ, А(ха, уа) и В(хв, ув), l=корень из (ха+уа)^2+(хв+ув)^2
- 27.05.2016 21:11
- Информатика
- remove_red_eye 16946
- thumb_up 41
Ответы и объяснения 1
Внимание! Если программа не работает, обновите версию!
begin
var (xa,ya):=ReadReal2('Введите координаты х и у точки А:');
var (xb,yb):=ReadReal2('Введите координаты х и у точки B:');
Writeln('Длина отрезка АВ равна ',Sqrt(Sqr(xb-xa)+Sqr(yb-ya)))
end.
Пример
Введите координаты х и у точки А: 3.7 -2.96
Введите координаты х и у точки B: 11 8.4
Длина отрезка АВ равна 13.503318110746
- 28.05.2016 08:40
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.