Вопрос по информатике:
Используя признаки делимости, написать программу в паскале, которая проверяет, делится ли натуральное число k на 4 (две последние цифры нули или образуют число, делящееся на 4).
- 08.10.2017 03:22
- Информатика
- remove_red_eye 599
- thumb_up 14
Ответы и объяснения 2
var k, a:integer;
begin
readln(k);
a:=k mod 100;
if(a=0) or (a mod 4=0) then write('Да')
else write('Нет')
end.
- 09.10.2017 23:30
- thumb_up 44
Внимание! Если программа не работает, обновите версию!
begin
var k:=ReadInteger('n=');
var a:=k mod 10; // поледняя цифра
var b:=(k mod 100) div 10; // предпоследняя цифра
if (a=0) and (b=0) or ((10*b+a) mod 4=0) then Writeln('Делится на 4')
else Writeln('Не делится на 4')
end.
Пример
n= 567264
Делится на 4
- 01.01.1970 00:00
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.